Unsupported compiler ‘GCC 4.2’ selected for architecture ‘i386’

xcode build errors:

Unsupported compiler ‘GCC 4.2’ selected for architecture ‘i386’

Solution:

This can be caused by importing a project for a pre- iOS 5 SDK into a copy of xcode with iOS 5 SDK only.

To fix, click your Project -> Build Settings.  Then under Build Options, there is an entry for Compiler for C/C++/Objective-C.  Choose Apple LLVM compiler 3.0.

There is a chance this could effect other aspects of your binaries as you are using a new compiler, so  YMMV.  That being said, it’s so far caused no issues for me.